This may represent an issue with your advertising API credentials.

I have provided some details on it below - including a workaround provided by Amazon:

DETAILS:

  1. Amazon PPC uses two API connections from Amazon -- "MWS API" and "Advertising API".   (Both are required by PPC Scope due to some of the advanced features offered.)
  2. MWS API uses your seller marketplace domains such as .com, .co.uk, etc.
  3. Advertising API only works with .com marketplace for authentication, regardless of which marketplace you are selling on.
  4. The first step in PPCScope authorization is to connect MWS API.
  5. The second step is the Advertising API authorization.

If you use a single login (email address) in Seller Central for all your marketplaces-- there is a known bug within Amazon's Advertising API connection process that may prevent properly connecting for all accounts:

WORKAROUND:

  1. In order to get around this issue, Amazon recommends you create a separate guest user account in Seller Central for each of marketplace not connecting that will be used to re-authenticate in PPC Scope for the marketplace:
    https://sellercentral-europe.amazon.com/gp/help/help-popup.html/?itemID=901
  2. Once the above guest user account is created, login to your PPCScope account, then navigate to Settings -> Account Settings > Amazon Accounts
  3. On the Amazon Accounts tab, click on 'Connect Sponsored Ads API' orange link for each EU marketplace being added and authorized.
  4. When redirected to the .com domain on Amazon's side use the new users created in workaround step 1 above for each of the respective accounts.

Did this answer your question?